Description

STEP File Browser is a simple utility for viewing STEP Part 21 files under Windows. It uses color to highlight syntactic elements of a file, such as entity IDs, references to entities, and text strings. It also uses entity references as hypertext links to corresponding entity definitions. This allows you to work with the program in a similar way as you would work with a Web browser.

STEP File Browser

STEP File Browser

The program keeps track of your browsing, so you can use the Navigate | Back and Navigate | Forward commands the same way as you do when browsing the Web. It also allows you to use bookmarks to mark lines of the file to quickly return later to the specified position. The bookmarks are sorted so you can use the Navigate | Previous Bookmark and the Navigate | Next Bookmark commands to move along the sequence of bookmarks.

You can use any editor you specify (Windows Notepad is the default) to edit the STEP file.

Command Line

The STEP File Browser is only available on Windows platforms. The STEP Check and Browse tool is available on all platforms. The file browser can be started using the following command line:

stepbrws [options] <STEP file name>

The following are the command-line options used by STEP File Browser:

-line <number>
Opens the file and scrolls to the specified line.
-entity <ID>
Opens the file and jumps to the definition of the given entity.
-pagesize <size>
Specifies the size of the file page in kilobytes.
-maxwhole <size>
Specifies the maximum file size in kilobytes to load as a whole.
-help
Shows the Help and exit.

Using STEP File Browser

To open a STEP file choose Open on the File menu or click on the toolbar. STEP File Browser will show the Open File dialog box. Using this dialog box you can locate the file on the disk and open it.

Once the file is open its contents will be displayed with syntax elements highlighted using different colors. You can use the scrollbar, entity references, bookmarks, as well the navigation commands on the Navigate menu to move around the file.

Entity references are similar to links on a Web page -- when you click them the page will be scrolled to the place where the referred entity is defined. The line with the referred entity will also be marked by a bookmark symbol ♦. This will allow you to return quickly to this place later.

You can also add bookmarks at any line of the file. To add a bookmark move the pointer beyond the left boundary of the text. The pointer will become a . Click once to add a bookmark at an unmarked line or remove a bookmark from a marked line. Bookmarks are sorted according to their order in the file. Use the Navigate | Previous Bookmark and the Navigate | Next Bookmark commands to navigate the bookmarks. To remove all bookmarks choose Remove All Bookmarks on the Navigate menu.

Large files may not be loaded in the browser at once, but in pages of a user-defined size. This allows the browser to use less memory and respond faster to user commands. When you scroll a large file, new pages will be loaded and old ones discarded as soon as you scroll beyond the page boundary. This process is fast enough to be hardly noticeable. The same is true when you use hypertext links or bookmarks.

The page size and the maximum file size before the browser starts using paging can be set using the View | Options command or through command-line options. These values are then stored in the system registry, so you only have to specify them when you wish to change them. The values are given in kilobytes. The default page size is 100 kilobytes, and the default maximum file size before the browser begins to split files into pages is 100 kilobytes.

Menus

File Menu

Open

(Also <Ctrl+O>) Shows the Open File dialog box. Using this dialog you can browse the file system and locate the file to open.

Reload

(Also <F5>) Reloads the open file. This is useful when you used the Edit command to edit the file.

Edit

(Also <Ctrl+E>) Opens an editor and loads the current file into it. You can specify what editor to use in the View | Options command.

Exit

(Also <Esc>) Closes the STEP File Browser window and quits the program.

View Menu

Options

(Also <Alt+Enter>) Displays the Options dialog box shown below. Using this dialog box you can select colors for syntax highlighting, default font, paging options, and the editor used to modify STEP files.

Options Dialog

Options Dialog

Statistics

Displays the Statistics dialog box shown below. This dialog box contains some statistical information about the file, such as the total number of entities in the file, the number of entity types, and the number of simple and complex entities.

Statistics Dialog

Statistics Dialog

Navigate Menu

History

(Also <Ctrl+H>) Use this command to display the History dialog box with the navigation sequence. A navigation sequence is formed when you move across the file using hypertext jumps at entity references.

History Dialog

History Dialog

The History dialog box contains a navigation sequence list. The list displays the lines from the file at the locations in the navigation sequence. Select an item in the list and then click Go to scroll the view directly to this location. You can also double-click an item to achieve the same result. Click the Reset button to clear the navigation sequence.

Back

(Also <Alt+Left Arrow>) Scrolls to the previous location in the navigation sequence. A navigation sequence is formed when you move across the file using hyperlinks at entity references.

Forward

(Also <Alt+Right Arrow>) Scrolls to the next location in the navigation sequence.

Home

(Also <Home>) Scrolls to the beginning of the file.

End

(Also <End>) Scrolls to the end of the file.

Find

(Also <Ctrl+F>) Searches for a specific text in a file. This command displays the Find dialog box.

Find Dialog

Find Dialog

Type the text to find in the Find what box. Select the options and the direction to search and click the Find Next button.

The Find what box keeps a list of the used search patterns. To open the list, click the button.

Used In

(Also <Ctrl+U>) Displays the Used In dialog box shown below. In the Entity ID box type the entity ID for which you want to find the use list and then click Find. The Browser will generate a list of all entities that use the entity you have given. To display one of the found entities, click Go.

Usedin Dialog

Usedin Dialog

Previous Bookmark

(Also <Ctrl+F2>) Scrolls the text to the location of the previous bookmark.

Next Bookmark

(Also <Shift+F2>) Scrolls the text to the location of the next bookmark.

Remove All Bookmarks

Removes all bookmarks from the open file.

Help Menu

STEP File Browser Help

(Also <F1>) Shows the context-sensitive Help, which is the help information relevant to the current program context -- active window, menu, dialog box, etc.

Contents and Index

(Also <Ctrl+F1>) Displays the Help browser. The Help browser is used to navigate through Help topics using table of contents, index, text search, and navigation buttons.

What's This?

(Also <Shift+F1>) Puts STEP File Browser into the Help mode.

This command will change the mouse pointer to an to indicate that the browser is in the Help mode. Click a menu command or toolbar button to get information about this command or button.

STEP Tools on the Web

Displays a menu with the following commands:

About STEP File Browser

Displays the copyright notice, version number and the license information of your copy of STEP File Browser.

Context menu

The context menu provides detailed information about a single instance in various forms. Place the cursor over the instance you are interested in, then click the right mouse button to display the context menu.

Used In

This provides a shortcut to the Used In dialog box. See Navigate Menu for more information.

Attributes

Use this command to display the detailed information about entity attributes. This command shows the Entity Attributes dialog box:

Attribute Dialog

Attribute Dialog

This dialog box displays the EXPRESS definitions of entity attributes as described in the file's schema. The name column lists the name of the attributes, the type column lists the EXPRESS types, and the value column lists their values as defined in the STEP file.

Note: The defined EXPRESS types are not supported, for example for a type defined as:

    TYPE area_measure = REAL;
    END_TYPE;

the displayed type will be REAL.

XML

Use this command to view the XML instance data of the selected entity formatted in CEB format. This command shows the XML Instance Data dialog box:

XML Dialog

XML Dialog

This dialog box displays the XML definition of the entity attributes in the Internet Explorer format. This format allows you to collapse/expand XML nodes by clicking the -/+ signs next to the node names.

 

Toolbar

The toolbar is normally placed across the top of the main window, under the menu bar. The toolbar buttons provide quick mouse access to menu commands. The toolbar buttons and their corresponding commands are described below.

Click

To

 

Open a file.

 

View History.

 

Go to the previous location in the navigation sequence.

 

Go to the next location in the navigation sequence.

 

Scroll to the beginning of the file.

 

Scroll to the end of the file.

 

Reload the file.

 

Find a text in the file.

 

Scroll to the previous bookmark.

 

Scroll to the next bookmark.

 

Delete all bookmarks.

 

Start the editor to edit the open file.

 

Display the Working Set dialog box.

 

Display the Help browser.

 

Put the browser into the Help mode.

 

Quit the program.

Keyboard Shortcuts

The following keyboard shortcuts can be used with STEP File Browser.

Use

To

Alt+Left Arrow

Go to the previous location in the navigation sequence.

Alt+Right Arrow

Go to the next location in the navigation sequence.

Up Arrow

Scroll up one line.

Down Arrow

Scroll down one line.

Home

Scroll to the beginning of the file.

End

Scroll to the end of the file.

Page Up

Scroll up one screen.

Page Down

Scroll down one screen.

Ctrl+E

Open the file in an editor.

Ctrl+F

Find a text in the file.

Ctrl+O

Open a STEP file.

Ctrl+U

Find the entities the selected entity is used in.

Ctrl+W

View and edit the working set.

Esc

Quit the browser.

Alt+Enter

Display the Options dialog box.

F1

Get help on the current context.

Ctrl+F1

Display the Help browser.

Shift+F1

Put the program into the Help mode.

Ctrl+F2

Go to the previous bookmark.

Shift+F2

Go to the next bookmark.

F5

Reload the open file.